プラグインをアップデートしたらエラいことになった話

プラグインをいくつかインストールしている。

いつも通りにログインしたら、プラグインのアップデートのお知らせが。

アップデートした後で(ちゃんと終わっていたはず)、投稿一覧に移動したら、「解析エラー、構文エラー予期しないT_FUNCTIONライン902」というエラーが出て、ログインできない状態に。

いったんは、ブラウザの「戻る」を使ってログアウトしたけれど、その後は上のエラーが出て、完全にログインできない状態。

iPhoneを使ってみたり、レノボのタブレットを使ってみたけれど、ログインできない(当たり前)。

iPadminiを使って色々調べた結果、レンタルサーバーのファイルマネージャーから、階層をたどってプラグインというフォルダまで言って、問題のプラグイン(wp-slimstat)を自分のパソコンにダウンロードした。

けれどもPHPには詳しくないので編集はあきらめた。

ライン902ってことは、902行目ってことでしょ?

もう一度iPadminiを使って調べて、プラグインフォルダの中の、wp-slimstatを削除した。(パソコンにダウンロードしているので、だめならアップロードできる)。

レンタルサーバーをログアウトして、再度Wordpressにログインしたら、無事にログインできて、今ブログを書いている。

私のようにアップデートして失敗した人がいるのかな?

アップデート完了したから画面移動したのに、本当は完了していなかったのか?

それとも、アップデートしたらエラーが出るような不完全なものだったのか?

これからは、アップデートのお知らせが来ても、すぐには実行しないでおこう。

iPadminiを手元に置いておくと本当に助かる。

今後のために、記録に残した。